Quand je lance flutter sur l’invite de commande, il se ferme

Salut es que quelqu’un peut m’aider ? Quand je lance Flutter dans l’invite de commande, l’invite se ferme directement.
Pourtant j’ai suivis les instructions d’installation.

Salut,

Et en essayant d’autres commandes comme « flutter doctor » ?

Pareil l’invite se ferme directement. J’ai retirer le fichier flutter du dossier dev et la l’invite me dit que flutter n’est pas reconnu, et quand je le remet l’invite se referme il donc un problème avec le fichier téléchargé ?

Quel système d’exploitation as-tu ? il faut aussi la version.
Ensuite quelle version de Flutter as-tu téléchargé ?

ma version :

et fluter :

J’ai pris la version stable.

git clone https://github.com/flutter/flutter.git -b stable

windows 7 32 bits et la version de flutter est la stable

Flutter ne supporte pas les versions 32 bits, il faut avoir au moins windows 7 64 bits.

Operating Systems: Windows 7 SP1 or later (64-bit), x86-64 based

Il est vrai que je n’insiste pas dessus dans le cours, cela va me permettre d’améliorer cela.

super merci je vais l’acheter du coup merci.

Salut Stephan,

J’ai installé Windows 7 64 bits, mais j’ai toujours le même problèmes des que je lance flutter sur l’invite de commande l’invite se ferme directement.

C’est déjà cela de sûr.

Bon apparement c’est la version de PowerShell sur ton Windows qui est trop ancienne.
Flutter nécessite la version 5.0 aussi disponible par défaut sur windows 10.

J’ai déplacé et renommé ce sujet pour que chacun est accès à cette information :slight_smile:

Super merci.

Bon ben j’ai installé la mise à jour ces toujours pareil, je ne comprend pas ?

L’idéal serait de faire toutes les mises à jour de windows 7 ou mieux encore d’avoir windows 10.

Regarde aussi si tu remplis bien toutes les conditions ci-dessous :

  • Operating Systems: Windows 7 SP1 or later (64-bit), x86-64 based
  • Disk Space: 1.64 GB (does not include disk space for IDE/tools).
  • Tools: Flutter depends on these tools being available in your environment.
    • Windows PowerShell 5.0 or newer (this is pre-installed with Windows 10)
    • Git for Windows 2.x, with the Use Git from the Windows Command Prompt option.If Git for Windows is already installed, make sure you can run git commands from the command prompt or PowerShell.

Avais-tu installé Git aussi ?
Qu’est-ce que te dit la commande « Get-Host | Select-Object Version » dans ton terminal ?

oui, la commande renvoie « commande no found »

« command not found » je voulais dire

Si flutter crash dès son lancement c’est qu’il lui manque un composant ou que quelque chose le bloque.

Vérifie ton pare-feu / antivirus quitte à tester sans, aussi que Git soit bien installé et accessible en tapant « git » dans ton terminal.

git est bien installé :

Apres désactivation des pare feu et antivirus ces pareil.