Probleme de gradle

salut les amis, après avoir refaire mon système et réinstaller tout ce qu’il faut pour développer avec Flutter je n’arrive pas lancer une application que j’ai commencer a faire avec flutter 1.17

voici ce que me donne « flutter doctor -v »

Est-ce que la configuration de l’application est faites pour que ton application soit signée ? Car le message d’erreur indique un problème de ce genre. Regarde au niveau de ton fichier build.gradle qui se trouve dans le dossier android/app, tu peux faire aussi un flutter clean pour nettoyer le projet.

voici ce qui me donne un flutter clean:

pour le gradle, je n’ai jamais eu a le toucher mais voici ce qu’il contient:

def localProperties = new Properties()

def localPropertiesFile = rootProject.file('local.properties')

if (localPropertiesFile.exists()) {

    localPropertiesFile.withReader('UTF-8') { reader ->

        localProperties.load(reader)

    }

}

def flutterRoot = localProperties.getProperty('flutter.sdk')

if (flutterRoot == null) {

    throw new GradleException("Flutter SDK not found. Define location with flutter.sdk in the local.properties file.")

}

def flutterVersionCode = localProperties.getProperty('flutter.versionCode')

if (flutterVersionCode == null) {

    flutterVersionCode = '1'

}

def flutterVersionName = localProperties.getProperty('flutter.versionName')

if (flutterVersionName == null) {

    flutterVersionName = '1.0'

}

apply plugin: 'com.android.application'

apply plugin: 'kotlin-android'

apply from: "$flutterRoot/packages/flutter_tools/gradle/flutter.gradle"

android {

    compileSdkVersion 28

    sourceSets {

        main.java.srcDirs += 'src/main/kotlin'

    }

    lintOptions {

        disable 'InvalidPackage'

    }

    defaultConfig {

        // TODO: Specify your own unique Application ID (https://developer.android.com/studio/build/application-id.html).

        applicationId "com.example.i_can_do_it"

        minSdkVersion 16

        targetSdkVersion 28

        versionCode flutterVersionCode.toInteger()

        versionName flutterVersionName

    }

    buildTypes {

        release {

            // TODO: Add your own signing config for the release build.

            // Signing with the debug keys for now, so `flutter run --release` works.

            signingConfig signingConfigs.debug

        }

    }

}

flutter {

    source '../..'

}

dependencies {

    implementation "org.jetbrains.kotlin:kotlin-stdlib-jdk7:$kotlin_version"

}

c’est pareil pour tout mes autres projets.

Essaye de supprimer manuellement le dossier build, apparement il y a un autre logiciel qui l’utilise.

j’ai fait cela ça donne le même résultat. Alors j’ai créer un nouveau projet et j’ai fait un copier coller de mon code et j’ai lancer ça fonctionne bien. cependant s’il faut que je fasse cela sur tout mes projets, cela devient un problème sans oublier les projets qui sont connecter à GitHub.

je viens de cloner un de mes projet sur GitHub et ça passe, reste plus que mes projets qui sont en local. Je tien a mentionné que j’ai refaire mon système d’exploite, peut-être est-ce de là que vient le problème.

Essaye de supprimer le dossier Android et iOS puis de faire un flutter create .

je viens d’essayer et c’est pareille.

Cela peut être plein de chose, comme les permissions sur ton système d’exploitation.

d’accord je vais faire du copier coller alors. Et cette fois-ci je vais mettre tous mes projets sur GitLab, ainsi j’aurai plus ce problème a l’avenir. Merci pour l’aide