Flutter downgrade ne fonctionne pas

Bonjour, je suis entrain de suivre le cours et on me demande de passer à une version antérieur pour mieux suivre le cours précisement à la version flutter 1.22.0 mais malheuresement quand je saisi la commande flutter downgrade , j’obtiens un message : C:\Users\AKPAGNI>flutter downgrade
There is no previously recorded version for channel « stable ».

Merci de donner un coup de pouce svp

Bonjour,

Oui, malheureusement la commande ne fonctionne pas très bien avec les dernières versions.

Voici les liens pour télécharger en zip la version de Flutter 1.22 :

Windows : https://storage.googleapis.com/flutter_infra/releases/stable/windows/flutter_windows_1.22.0-stable.zip

macOS : https://storage.googleapis.com/flutter_infra/releases/stable/macos/flutter_macos_1.22.0-stable.zip

Ensuite, il faudra remplacer le contenu de votre ancien dossier SDK Flutter avec cette version.

1 J'aime

Ma solution a moi est d’avoir deux version du sdk flutter par défaut c’est la dernière version d’utilise mais pour mes ancien projet je spécifie la version. FVM (Flutter Version Management) permet de le faire mais je cette méthode où tu as toutes as les deux version et tu spécifie pour chaque projet que tu utilises VsCode ou Android Studio. Je vous laisse le lien, descendez un peu pour android studio.

1 J'aime